Bug report #16566

[qgis-server] wms layer in pdf export hide other layers

Added by Lionel Bargeot almost 7 years ago. Updated almost 7 years ago.

Status:Closed
Priority:High
Assignee:-
Category:QGIS Server
Affected QGIS version:2.18.7 Regression?:Yes
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24468

Description

Hi

with qgis-server 2.18.7, a GetMap with pdf output format is wrong if a WMS layer is in the list. If I use a WMS Layer as baselayer with full opacity, it hides all other layers in the pdf.
The problem is not present with qgis-server 2.14.

Regards
Lionel

History

#1 Updated by Giovanni Manghi almost 7 years ago

  • Priority changed from Normal to High

I have also been bitten by this problem.

#2 Updated by René-Luc ReLuc almost 7 years ago

Hi Lionel,

If you generates, PDF with the request GetPrint, the parameters LAYERS have changed between 2.14 and 2.18. The layer name ordered has been inverted to be the same has in GetMap and other request.

#3 Updated by Giovanni Manghi almost 7 years ago

René-Luc ReLuc wrote:

Hi Lionel,

If you generates, PDF with the request GetPrint, the parameters LAYERS have changed between 2.14 and 2.18. The layer name ordered has been inverted to be the same has in GetMap and other request.

should we close this then?

#4 Updated by René-Luc ReLuc almost 7 years ago

We should close it if this is about GetPrint.

#5 Updated by Lionel Bargeot almost 7 years ago

  • Status changed from Open to Closed

I understand the problem now.
My GetMap request is générated by a web application (Lizmap). I will have a look in this direction.
Thanks for all.

#7 Updated by Lionel Bargeot almost 7 years ago

and thanks again. all is clear now.

Also available in: Atom PDF