Bug report #1655

Lacking translation causes malfunction

Added by vince - over 10 years ago. Updated over 10 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:C++ Plugins
Affected QGIS version: Regression?:No
Operating System:OS X Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11715

Description

When a release is done (here, e.g. 1.1.0), please insure all the translation for major item are available, otherwise I18 versions sometimes won't work.
For exemple, the 1.1.0 does not include a translation for the tr ("Shapefile ...") found in line 170 of qgsspit.cpp. As a result, the corresponding file selector will be called with a null filter, and the user won't be able to pick any file. Getting rid of the tr () fixes the misbehaviour (temporarily, until a proper translation will be available).

sshot.jpg - Screen shot of the Spit add file dialog box (202 KB) vince -, 2009-04-26 12:33 AM

Associated revisions

Revision e92f31d8
Added by Jürgen Fischer over 10 years ago

fix french translation (fixes #1655)

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 1819a5dc
Added by Jürgen Fischer over 10 years ago

fix french translation (fixes #1655)

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by vince - over 10 years ago

PS : this concerns the French version

#2 Updated by Jürgen Fischer over 10 years ago

Replying to [comment:1 vince]:

PS : this concerns the French version

what's wrong with the translation in line 20041 of qgis_fr.ts?

#3 Updated by vince - over 10 years ago

It has a unique ; instead of a ;; separator. That makes it non-functional. Sorry for that, I thought the translation was non-existant, so I didn't checked. Will modify it.

Besides, I've joined what the File Dialog Box looks like on my Mac: it is impossible to select the encoding, the corresponding box does not appear on screen. But I'll try to fix the translation first, then try again.

#4 Updated by vince - over 10 years ago

I've quickly reviewed the French translation. It is a bit approximative (typing errors here and there, a lot of things lacking), so I'll update it and propose you an up-to-date version.

#5 Updated by Jürgen Fischer over 10 years ago

  • Resolution set to fixed
  • Status changed from Open to Closed

Replying to [comment:4 vince]:

I've quickly reviewed the French translation. It is a bit approximative (typing errors here and there, a lot of things lacking), so I'll update it and propose you an up-to-date version.

I've fixed the bug in the dialog translation in 1819a5dc (SVN r10656), but all additinal improvements are still most welcome.

Also available in: Atom PDF