Bug report #16528

Adding a WCS service does not show up in service dropdown, works in browser (strange Dialog title)

Added by Richard Duivenvoorde about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Web Services clients/WCS
Affected QGIS version:master Regression?:Yes
Operating System:Debian Testing Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24434

Description

In current master(bfb62c4be9), I cannot add a new WCS service, while I can do that in 2.14 or 2.18

1) click button 'Add WCS Layer'
2) in dialog click button New
3) give title: RIVM
4) give url: http://geodata.rivm.nl/geoserver/wcs
5) click OK
6) the connection is not visible in the dropdown

I tried this both with my current .qgis2 config and a fresh one via 'qgis --configpath /tmp/foo'

I do not see any indication of misbehaving in debug info or messages

wcs.png (40.4 KB) Richard Duivenvoorde, 2017-05-09 01:44 PM

Associated revisions

Revision 20a54b1c
Added by Richard Duivenvoorde almost 3 years ago

Fix #16528 mix of Qgis en qgis as root in settins

On Linux the use of Qgis and qgis as root for connection settings
makes it currently impossible to add a new WCS connection

Fixes #16528

History

#1 Updated by Giovanni Manghi about 3 years ago

  • Status changed from Open to Feedback

Works here on Windows/osgeo4w.

#2 Updated by Richard Duivenvoorde about 3 years ago

Further checking: if I create a new connection in Browser panel, at least it shows up (see attachment).

BUT look at the 'Dialog title': it says: "Create a new CS/ Connection" ?

And THEN at least THAT connection shows up in the WCS dialog...
Though if I edit it, the URL appears emtpy...

Trying to add a new one does not work though.
Adding the RIVM one from the opening description works (in the browser!), and then shows up then in the Dialog too. But adding a new one in the browser just does not work.

Will try tomorrow at a client on Windows

#3 Updated by Richard Duivenvoorde about 3 years ago

  • Subject changed from Adding a WCS service does not show up in service dropdown to Adding a WCS service does not show up in service dropdown, works in browser (strange Dialog title)

#4 Updated by Richard Duivenvoorde about 3 years ago

Confirmed here: on Windows OK, will try to find another Linux machine to test.

#5 Updated by Raymond Nijssen about 3 years ago

Same problem here, on linux as well.

But when I repeat adding this same WCS server, I get the message "Should the existing connection rivm be overwritten?" so there seems to be something saved. Listbox stays empty though.

#7 Updated by Richard Duivenvoorde almost 3 years ago

  • % Done changed from 0 to 100
  • Status changed from Feedback to Closed

Also available in: Atom PDF