Bug report #16439

QGIS crashes on startup when plugin manager last closed viewing the settings tab

Added by Mathieu Pellerin - nIRV over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:Mathieu Pellerin - nIRV
Category:Plugin Manager
Affected QGIS version:2.18.5 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:24348

Description

QGIS will crash on startup when a user last closed his/her plugin manager viewing the settings tab.

The long story short here is that due to the plugin manager's not having the same amount of optionStacks and optionList items, the settings stack index is 1, while the optionList index is 3; QgsOptionDiloagBase saving/restoring sets both the optionList and optionStack index to the latter. In the context of the plugin manager, this leads to the dialog trying to update its window title upon creation using mModelProxy's mModelPlugins which isn't initialized and crashes QGIS.

The only way to fix this is either via editing QGIS2.conf/QGIS3.conf and manually changing the PluginManager\\tab value back to 0, or delete the whole file. I imagine this must have silently affected a number of users who couldn't dissect crash properly.

Fix coming in soon.

Associated revisions

Revision 40dac8f0
Added by Mathieu Pellerin - nIRV over 2 years ago

[plugin manager] fix QGIS startup crash (fixes #16439) (#4360)

History

#1 Updated by Mathieu Pellerin - nIRV over 2 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF