Bug report #16438

Categorized layer crashes when deselecting

Added by Andre Jesus over 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Symbology
Affected QGIS version:2.14.13 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:24347

Description

Several clients are getting Freezes/Force closes when using Categorized.

The layer is categorized correctly and works as usual, but if you deselect any categorized item It either freezes QGIS or force close it.

Users report me this error:

Or going strait to FC, dumpfile attached.

dp1.rar (2.61 MB) Andre Jesus, 2017-04-11 10:10 AM

dp2.rar (2.62 MB) Andre Jesus, 2017-04-11 10:10 AM

History

#1 Updated by Andre Jesus over 3 years ago

As a workaround, I apply Categorized and switch It to Rule Based. No error found that way.

#2 Updated by Giovanni Manghi over 3 years ago

  • Description updated (diff)
  • Status changed from Open to Feedback
  • Priority changed from Severe/Regression to High

Any kind of vector datasources?
Regardless of the project?
Can you attach a sample?
Did you tried removing all 3rd party plugins/removing the .qgis2 folder?

#3 Updated by Giovanni Manghi over 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#4 Updated by Giovanni Manghi over 3 years ago

  • Category set to Symbology
  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

#5 Updated by Andre Jesus almost 3 years ago

  • Status changed from Closed to Reopened

Error is present in 2.14.18, downloading 2.14.19... but should be the same as I see no entry in the changelog

please disconsider this, only two users are reporting this problem e looks like dirty registry entries...

#6 Updated by Giovanni Manghi almost 3 years ago

  • Status changed from Reopened to Feedback
  • Resolution deleted (fixed/implemented)

Did you tried 2.18 (there are no more fixes for 2.14)?

Any kind of vector datasources?
Regardless of the project?
Can you attach a sample?
Did you tried removing all 3rd party plugins/removing the .qgis2 folder?

#7 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF