Bug report #16423

Broken io_gdal raster import in SAGA LTR package shipped with OSGeo4W

Added by Giovanni Manghi over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Build/Install
Affected QGIS version:2.18.7 Regression?:Yes
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:24332

Description

This is a really weird issue. This ticket is meant to replace #16408 for sake of clarity.

This only affects Windows.

1) In OSGeo4w installer the option for SAGA LTR says "2.3.1", but once installed "saga_cmd" says 2.3.2, which is weird per se as SAGA 2.3.2 does not exist:

https://sourceforge.net/projects/saga-gis/files/SAGA%20-%202.3/

2) if launching SAGA GUI of this SAGA installation it apparently seems all ok, but for instance it misses the "Import > GDAL/OGR" tools which are available in any older and newer (or even the same) versions downloaded from SAGA site. This could be related to the next point, that is the more important

3) In this OSGEo4W SAGA LTR install the raster import operation (done with the "io_gdal" module) produces a WRONG raster, where 1 are replaced with NULLs. This DOES NOT happen in any older and newer (or even the same) versions downloaded from SAGA site. This is of course a deal breaker for Processing because it calls io_gdal any time a SAGA raster tool is used

You can test with this input

https://cld.pt/dl/download/6ac21f8c-0244-45a5-823e-6047bb99b208/bacias_lee_2014_2018_17_Binary.tif

and this command

saga_cmd io_gdal 0 -TRANSFORM 1 -RESAMPLING 0 -GRIDS "imported_raster.sgrd" -FILES "bacias_lee_2014_2018_17_Binary.tif"


Related issues

Related to QGIS Application - Bug report #16422: Processing (on Windows): external SAGA does not work anymore Closed 2017-04-07

History

#1 Updated by Jürgen Fischer over 2 years ago

  • Resolution set to up/downstream

OSGeo4W issues...

#2 Updated by Giovanni Manghi over 2 years ago

  • Resolution deleted (up/downstream)

Jürgen Fischer wrote:

OSGeo4W issues...

OSGeo4W #527

#3 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to up/downstream

#4 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to Yes

#5 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Severe/Regression to High

#6 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No

#7 Updated by Giovanni Manghi over 2 years ago

  • Description updated (diff)
  • Affected QGIS version changed from 2.18.5 to 2.18.7

#8 Updated by Jürgen Fischer over 2 years ago

  • Related to Bug report #16422: Processing (on Windows): external SAGA does not work anymore added

#9 Updated by Pedro Venâncio over 2 years ago

I think this is fixed now, with saga-ltr-2.3.2-1 shipped with OSGeo4W.

https://trac.osgeo.org/osgeo4w/ticket/527

#10 Updated by Jürgen Fischer over 2 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF