Bug report #16412

QGIS Desktop 2.14.2 - doesn't save values in field Comment

Added by jose macau about 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Affected QGIS version:2.14.12 Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24321

Description

QGIS Desktop doesn't save values in column Comment, layer properties

History

#1 Updated by jose macau about 3 years ago

sorry, QGIS Desktop 2.14.12

QGIS Desktop doesn't save values in column Comment, field, layer properties

#2 Updated by jose macau about 3 years ago

QGIS Desktop only can get comment content from PostGis

#3 Updated by Andre Joost about 3 years ago

Does your Postgis table have a primary key?

If not, edit capabilities inside QGIS are limited. See https://gis.stackexchange.com/questions/157541/postgresql-trouble-editing-points-lines-polygons-in-qgis

#4 Updated by jose macau about 3 years ago

hi Andre Joost!

yes it does (pk)

#5 Updated by Giovanni Manghi about 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#6 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to invalid
  • Category set to GUI
  • Status changed from Open to Closed

The column has to be intended as read only, see

https://lists.osgeo.org/pipermail/qgis-developer/2015-April/037521.html

Also available in: Atom PDF