Bug report #16396

Inconsistent transparency behavior when using blending and PNG export

Added by Martin HOFFMANN over 3 years ago. Updated over 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:2.18.4 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24305

Description

Combination of blending techniques can be used to produce a composer map item that achieve transparency in composer view but is exported as an opaque white object when exporting to PNG.
I produced a demonstration .qgs file embedded in the attached zip.

This is what you see in the composer.
qgis_view
This is what you get when opening the resulting png using gimp.
gimp_view

As you might notice map 3 & 4 both achieve transparency because the yellow rectangle in the background is visible in the resulting png.
However a white background is applied on map 4 for whatever reason.

Tested on windows 10 & Ubuntu 14.04 with Qgis 2.18.5

20170330_bug_blending.zip - Qgis project demonstrating the bug (442 KB) Martin HOFFMANN, 2017-03-30 05:41 AM

qgis_view.png - qgis_view (126 KB) Martin HOFFMANN, 2017-03-30 05:41 AM

gimp_view.png - gimp_view (138 KB) Martin HOFFMANN, 2017-03-30 05:41 AM

History

#1 Updated by Giovanni Manghi about 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#2 Updated by J├╝rgen Fischer almost 3 years ago

  • Category set to Unknown

#3 Updated by salvatore fiandaca over 1 year ago

  • Description updated (diff)
  • Status changed from Open to Closed

trying in 3.4.4-3 it is not possible to activate the theme 'masked' in the TOC, therefore it is evaluated as a problem of 2.18 and not of 3.4

#4 Updated by Giovanni Manghi over 1 year ago

  • Resolution set to fixed/implemented

salvatore fiandaca wrote:

trying in 3.4.4-3 it is not possible to activate the theme 'masked' in the TOC, therefore it is evaluated as a problem of 2.18 and not of 3.4

when closing a ticket please add a proper resolution.

#5 Updated by salvatore fiandaca over 1 year ago

  • Status changed from Closed to Reopened

I'm sorry,
I studied the problem and in my opinion is a problem limited to 2.x; to avoid problems reapro issue

#6 Updated by Giovanni Manghi over 1 year ago

  • Status changed from Reopened to Closed

salvatore fiandaca wrote:

I'm sorry,
I studied the problem and in my opinion is a problem limited to 2.x; to avoid problems reapro issue

If a ticket needs to be reopened then resolution must be removed. Anyway if is a 2.x only issue this must be ticket, as 2.* is EOL.

Also available in: Atom PDF