Bug report #16379

2.18.5, processing and metasearch not loaded

Added by Gerhard Spieles over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Build/Install
Affected QGIS version:2.18.4 Regression?:No
Operating System:win Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24289

Description

After install 2.18.5, QGIS cant load modules processing and metasearch
Stacktrace shows Python errors
processing reports: ImportError: No module named yaml
metasearch rports: ImportError: No module named owslib.csw

Files are attatched

2_18_5_processing_not_loaded.txt Magnifier (4.46 KB) Gerhard Spieles, 2017-03-27 01:33 AM

2_18_5_metasearch_not_loaded.txt Magnifier (3.18 KB) Gerhard Spieles, 2017-03-27 01:33 AM

History

#1 Updated by João Gaspar over 2 years ago

Hi Gerhard,
in my installation works fine.
My environment: Win 7 64-bits / OsGeo Installer 64-bits QGIS 2.18.4

You are using the standalone or osgeo installer?

delete .qgis2 foler (C:\\Users\
ame_of_user\\.qgis2)
Open QGIS and see if works.

If don't work try to re-install.

Regards,
João Gaspar

#2 Updated by Gerhard Spieles over 2 years ago

Hi,
2.18.4 is OK.
The new published Release 2.18.5 is infected, also 2.14.13.

In the ticket form, you have to select an entry in the field "Affected Version" and 2.18.5 is not yet an element of the list.
So the the ticket is in this field missleading.

#3 Updated by Jürgen Fischer over 2 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Also available in: Atom PDF