Bug report #16314

Processing: Get scripts /models from online collection crashes QGIS

Added by Andreas Plesch over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:High
Assignee:Victor Olaya
Category:Processing/Core
Affected QGIS version:2.18.3 Regression?:No
Operating System:Gentoo linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:24224

Description

Opening (double clicking) Get script (or models) from on-line collection in the Processing tool box crashes QGIS.

Here is the console output before the segmentation fault:

Warning: Object::connect: No such signal QWebPage::loadProgress(int)
Warning: Object::connect: No such signal QWebPage::unsupportedContent(QNetworkReply*)
Warning: Object::connect: No such signal QWebFrame::titleChanged(QString)
Warning: Object::connect: No such signal QWebPage::loadProgress(int)
Warning: Object::connect: No such signal QWebFrame::titleChanged(QString)
Warning: Object::connect: No such signal QWebFrame::iconChanged()
Warning: Object::connect: No such signal QWebFrame::urlChanged(QUrl)
Warning: Object::connect: No such signal QWebPage::loadStarted()
Warning: Object::connect: No such signal QWebPage::loadProgress(int)
Warning: Object::connect: No such signal QWebPage::statusBarMessage(QString)
Warning: Object::connect: No such signal QWebPage::linkClicked(QUrl)
Warning: Object::connect: No such signal QWebPage::selectionChanged()
Warning: Object::connect: No such signal QWebPage::microFocusChanged()
Warning: QMetaObject::invokeMethod: No such method QWebPage::repaintRequested(QRect)
Warning: QMetaObject::invokeMethod: No such method QWebPage::repaintRequested(QRect)
Warning: QMetaObject::invokeMethod: No such method QWebPage::repaintRequested(QRect)
Warning: QMetaObject::invokeMethod: No such method QWebPage::repaintRequested(QRect)
Warning: QMetaObject::invokeMethod: No such method QWebPage::repaintRequested(QRect)
Warning: QMetaObject::invokeMethod: No such method QWebPage::repaintRequested(QRect)
Segmentation fault

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • Priority changed from Normal to High
  • Status changed from Open to Feedback
  • Category changed from Processing/GUI to Processing/Core

Works fine on 2.18.4 on Ubuntu 16.04 installed from QGIS repos.

Please try 2.18.4 and report back, thanks.

#2 Updated by Andreas Plesch over 3 years ago

Will do when 2.18.4 becomes available on Gentoo. But I think it may be a platform issue and will file a bug on the gentoo bugtracker.

#3 Updated by Andreas Plesch over 3 years ago

  • Status changed from Feedback to Closed
  • % Done changed from 0 to 100

It turns out that 2.18.4 is available on Gentoo unstable. Installing with the (non-default) webkit USE keyword on gentoo leads to proper functioning of get scripts/models in the Processing toolbox. This bug can be closed here.
I opened https://bugs.gentoo.org/show_bug.cgi?id=612070 (for reference).

Also available in: Atom PDF