Bug report #16261

metasearch fails when catalogue entry provides full GetCapabilities URL with parameters

Added by Dave Sampson over 2 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:Tom Kralidis
Category:MetaSearch Catalogue Client
Affected QGIS version:2.18.4 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:24171

Description

As a metasearch user
I want to access entries in catalogues that include a full GetCapabilities URL
So that these types of URLS don't fail and I can view a WMS or other OGC service within QGIS

Details:
  1. Given this internal catalogue: http://INTRANET/geonetwork/srv/csw
  2. And a keyword search of "WMS"
  3. Resulting in a record entry with: http://INTRANET/arcgis/services/D01/0cb80e79-11df-4772-b7bd-f0ed2902cdb5/MapServer/WMSServer?request=GetCapabilities&service=WMS
    #Reults in the following error:
    ---------------------------
    WMS Provider
    ---------------------------
    The server you are trying to connect to does not seem to be a WMS server. Please check the URL.
    ---------------------------
    OK   Hide Details...   
    ---------------------------
    
  4. when you enter URL with double params (created by Metasearch) you also get the error

Likely issue is in metasearch sending OWSLib an invild URL because the catalogue maintains the full GetCap string. Not sure if best to fix in Metasearch or OWSLIB.

Due to various business rules the actual GetCap request is managed in the catalogue.

History

#1 Updated by Tom Kralidis over 2 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Implemented in 2.14 branch, 2.18 branch and master. Will be available on the next plugin release of MetaSearch or 2.14.13/2.18.5 on 24 March 2017 (whatever comes first)

Also available in: Atom PDF