Bug report #16254

clipping a CORINE landcover geotiff raster with a polygon misses a driver

Added by Davor Lister over 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:2.18.4 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:24164

Description

It says: "Output driver 'DTED' not recognised or does not support direct output file creation."
Upon inspection the Raster tab, at the bottom there is a "GdalTools Settings" option which opens a window to set GDAL paths, yet all are empty.
Installation was QGIS 2.18.3 installed by QGIS 64 bit install.
I also tried to fix it by installing Osgeo, which updated QGIS to QGIS 2.18.4 64 bit, but to no avail.

I found some workarounds for situations with "Output driver 'XXXX' not recognised or does not support direct output file creation.", (XXXX being some other formats) that involve warp function capabilities, but those are beyond my expertise.

History

#1 Updated by Davor Lister over 2 years ago

The source of landcover tiff file is here: http://land.copernicus.eu/pan-european/corine-land-cover

#2 Updated by Davor Lister over 2 years ago

  • Target version set to Version 2.18

I managed to clip the raster on a different computer, and with QGIS 2.14 on it. :)

On the affected machine I:
- reinstalled QGIS through Osgeo to version 2.18 - no joy;
- reinstalled QGIS through Osgeo to version 2.14 - no joy;
- deinstalled Osgeo and QGIS, and all their folders (or so I thought), and registry, restarted and put QGIS 2.14.12 - no joy

There is a difference between the 2 PCs that may be the cause of odd behaviour. The PC where it works fine is the one I have full control, and the affected PC I use as an user, but install things as a domain admin. Perhaps there is some access problem associated with such use. I'm afraid such behaviour will be difficult to duplicate on other machines.

#3 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to not reproducable
  • Status changed from Open to Closed

Davor Lister wrote:

I managed to clip the raster on a different computer, and with QGIS 2.14 on it. :)

On the affected machine I:
- reinstalled QGIS through Osgeo to version 2.18 - no joy;
- reinstalled QGIS through Osgeo to version 2.14 - no joy;
- deinstalled Osgeo and QGIS, and all their folders (or so I thought), and registry, restarted and put QGIS 2.14.12 - no joy

There is a difference between the 2 PCs that may be the cause of odd behaviour. The PC where it works fine is the one I have full control, and the affected PC I use as an user, but install things as a domain admin. Perhaps there is some access problem associated with such use. I'm afraid such behaviour will be difficult to duplicate on other machines.

On Win computers with strict policies about what can/can't be run by normal users, with installations done by admins but then used by normal users, etc. I sometimes seen this kind of problems.

Please try pinpoint the issue, and then eventually reopen this ticket.

#4 Updated by Jürgen Fischer almost 2 years ago

  • Category set to Unknown

Also available in: Atom PDF