Bug report #16186

Processing: Broken GRASS tools under Windows

Added by Giovanni Manghi over 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Build/Install
Affected QGIS version:2.18.13 Regression?:Yes
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:24096

Description

Under Windows all the GRASS7 tools that are .bat files (pointing to python scripts) are broken in processing, but does not seems to be a processing thing. They work ok under Linux (can test macOS too if necessary).

Error message is like this

"C:\\OSGEO4~1\\bin>v.dissolve input=tmp1487011631917 column="Concelho" output=output00e668ad483d4e65b2c382124335b3f7 --overwrite
'""' is not recognized as an internal or external command,
operable program or batch file. " ... any idea where to look in? Same commands on Windows/GRASS6 work ok.

this is on 2.14 to 2.18, cannot test on master/Windows as there is a python error on start that prevents Processing from loading.


Related issues

Duplicated by QGIS Application - Bug report #16922: Processing: GRASS7 v.dissolve broken under Windows Closed 2017-07-24

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Target version set to Version 2.18
  • Affected QGIS version changed from 2.18.3 to 2.18.4

#2 Updated by Giovanni Manghi over 2 years ago

  • Regression? set to Yes

#3 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Severe/Regression to High

#4 Updated by Giovanni Manghi over 2 years ago

  • Easy fix? set to No

#5 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Closed
  • Description updated (diff)
  • Resolution set to fixed/implemented

Somehow this seems to me fixed in 2.18.9 nightly.

#6 Updated by Giovanni Manghi about 2 years ago

  • Resolution deleted (fixed/implemented)
  • Affected QGIS version changed from 2.18.4 to 2.18.11
  • Status changed from Closed to Open

This has resurfaced in 2.18.10 and 11

#7 Updated by Giovanni Manghi about 2 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed/implemented

in a clean Windows testing VM, with qgis installed from scratch from osgeo4w I cannot replicate it anymore... this is puzzling.

#8 Updated by Jürgen Fischer about 2 years ago

  • Duplicated by Bug report #16922: Processing: GRASS7 v.dissolve broken under Windows added

#9 Updated by Giovanni Manghi about 2 years ago

  • Status changed from Closed to Open
  • Subject changed from Broken Processing/GRASS tools under Windows to Processing: Broken GRASS tools under Windows
  • Affected QGIS version changed from 2.18.11 to 2.18.13
  • Operating System set to Windows
  • Resolution deleted (fixed/implemented)

This as resurfaced. Tested on completely clean system.

#10 Updated by Giovanni Manghi almost 2 years ago

tools that can be tested if/when a patch will be proposed:

v.rast.stats
v.buffer
r.fillnulls

among the others.

#11 Updated by Giovanni Manghi almost 2 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

Closing again because on a completely clean (OS and osgeo4w) install all seems to work as expected. There is something (maybe an update? installing in parallel a standalone version?) that makes them stop to work... but was unable to pinpoint the issue.

Also available in: Atom PDF