Bug report #16138

Error executing algorithm Merge lines

Added by Pieter Brusselman over 2 years ago. Updated almost 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Unknown
Affected QGIS version:2.18.2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:24050

Description

When merging layers I get following message:

Error executing algorithm Merge lines {} field in layer {} has different data type than in other layers.

What am I doing:

I have some line--layers and some polygon-layers. I buffer the line-layers with a fixed distance buffer so I get all polygon-layers. Each polygon-layer is converted to lines. When merging all converted layers I get that message.

I tried to eliminate the layers who are responsible for the error. I found two. One was originaly a line-layer that I buffered, the other was originaly a polygon-layer. So I can't figure out if the bug is due to the buffering or not...

History

#1 Updated by Pieter Brusselman over 2 years ago

Apparently, if i merge all those layers 'by hand' outside a model, it works... Very, very strange behaviour

#2 Updated by Pieter Brusselman over 2 years ago

  • Status changed from Open to Closed

#3 Updated by Jürgen Fischer almost 2 years ago

  • Category set to Unknown

Also available in: Atom PDF