Bug report #1610

Update Preview in map composer doesn't work

Added by bjpfei - over 11 years ago. Updated over 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:-
Affected QGIS version: Regression?:No
Operating System:RedHat Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:11670

Description

It seems that the update preview button in the map composer doesn't work correct anymore.
Try this:

1.) open the map composer

2.) add a new map

3.) Select Cache in the preview box. The preview in the map is correct so far.

4.) Change the map in the main window eg change the zoom level or the extent

5.) Now try to update the preview in the map composer by pressing the update preview button. Nothing happens.

Qgis version is 1.0.2 code revision 10413.

It also happens with version 1.1.0 and code revision 10441

Thanks

History

#1 Updated by Marco Hugentobler over 11 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

This is intended behaviour. The extent of a composer map is independent of the main map extent. If you want the composer map to adapt to a changed main map extent, you need to press 'set to map canvas extent' button in the composer map widget.
Because both extents are different, it is e.g. possible to have multiple composer maps in one printout showing different parts of the map or to have an overview map at a different scale.

Also available in: Atom PDF