Bug report #15969

categorized labeled layers with virtual fields crash qgis

Added by Gerhard Spieles almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Labelling
Affected QGIS version:2.18.0 Regression?:No
Operating System:win Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:23885

Description

When you label categorized layers with virtual fields (e.g. $area), QGIS crash, when visibility is toggeled on/off.
Testproject is attached

test_categorize.zip (13.7 KB) Gerhard Spieles, 2016-12-11 06:42 AM

qgis2_18_4_crash_categorized_layer.jpg (102 KB) Gerhard Spieles, 2017-03-05 12:33 PM

History

#1 Updated by Saber Razmjooei almost 3 years ago

  • Priority changed from High to Severe/Regression
  • Target version changed from Version 2.18 to Version 2.14

It is even worse in 2.14

Marked it as regression and hopefully the fix will be backported to 2.14

#2 Updated by Giovanni Manghi over 2 years ago

  • Target version changed from Version 2.14 to Version 2.18
  • Status changed from Open to Feedback

I cannot replicate with the attached project and data on Windows and 2.18.4
can you test if in this version is fixed?

#3 Updated by Gerhard Spieles over 2 years ago

Just tested it with 2.18.4, win 10 and QGIS crash when toggling e.g the layer "second", categorie 1 from "on" to "off".
Screenshot is attached.

#4 Updated by Giovanni Manghi over 2 years ago

Gerhard Spieles wrote:

Just tested it with 2.18.4, win 10 and QGIS crash when toggling e.g the layer "second", categorie 1 from "on" to "off".
Screenshot is attached.

still cannot replicate. Please test with a clean encironment, by disabling/remeoving all the 3rd party plugins, removing the .qgis2 folder (you my want to make a backup first), etc.

#5 Updated by Gerhard Spieles over 2 years ago

Tested it again with a fresh intalled QGIS and no crash happens.
Also no crash on this machine, when i install the same 3rd party plugins.
The problems seems to cause from earlier version-entries in the .qgis2 folder or registry entries.

Thank you for the hints and the issue can be closed.

#6 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Also available in: Atom PDF