Bug report #15884

memory access exception at exit qgis 2.18

Added by Jan Heckman almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Build/Install
Affected QGIS version:2.18.0 Regression?:No
Operating System:windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:23802

Description

Hi,
Have this minor problem with several versions of Qgis desktop w and wo grass.
The dump file is attached.
From a chance I got to attach a debugger (no symbols) I think it's not a nullptr, but a oneptr, pun intended.
At some point I believed I caused it by modifying etc/ini/python-core.bat by adding the (2nd) line:
SET PYTHONPATH=%OSGEO4W_ROOT%\\apps\\qgis\\python;%PYTHONHOME%\\Lib\\site-packages;%PYTHONPATH%
to prevent python version mixup's, but I cannot get rid of the fault by removing the line.
OS: Win 7 64 (prof) and Win 10 64 (home)
Since I could not find a similar report (hope I didn't miss any), I filed this one.
Best regards
Jan

qgis-20161123-143537-14204-15436-0332f5a.dmp.7z - dump (3.98 MB) Jan Heckman, 2016-11-23 05:53 AM

History

#1 Updated by Giovanni Manghi over 2 years ago

  • Priority changed from Normal to High

#2 Updated by Giovanni Manghi over 2 years ago

  • Status changed from Open to Feedback
  • Category set to Build/Install

Can you please add detailed steps on how to replicate or just try 2.18.4/master and see if this is still valid? thanks.

#3 Updated by Giovanni Manghi over 2 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF