Bug report #15779

2.17 weekly and 2.18.0 both seem to render 1-bit tif raster grids slower than 2.16

Added by sand thorn almost 4 years ago. Updated about 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:2.18.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23700

Description

I can notice increased render time compared to 2.16.3, when moving my viewport around with 1-bit tif raster grid (with nodata transparency) layers enabled.

I thought it could be some kind of "debug" mode effects when released as 2.17-dev, but unfortunately 2.18 has the same effect.

I have only Skylake-U so it might be less noticeable in desktop CPU.

I now move back to 2.16.3 for quicker digitizing task.

Are there any changes in 2.17/2.18 that might cause this?

History

#1 Updated by sand thorn almost 4 years ago

  • Status changed from Open to Closed

Duplicate of issue #15796

#2 Updated by Jürgen Fischer about 3 years ago

  • Category set to Unknown

Also available in: Atom PDF