Bug report #15738

Repeated segfault when merging and editing polygons

Added by Karl Kastner almost 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Unknown
Affected QGIS version:2.14.1 Regression?:No
Operating System:Ubuntu Linux Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:23660

Description

Steps to reproduce:
Open the attached shape file that contains a set of polygons.
Select two polygons.
Merge the polygons.
Select the node tool.
Select a vertex.
Delete the vertex.
Keep selecting and deleting vertices until Qgis crashes.
Crashes on my machine at every attempt, but sometimes more, sometimes less vertices have to be deleted.
The merge step seems to be necessary to reproduce the bug.
The core dump is compressed 72MB and therefore not attached. I will provide the core dump on request.

test.tar.gz (20 KB) Karl Kastner, 2016-10-21 09:19 AM

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Priority changed from Normal to High

#2 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to not reproducable
  • Status changed from Open to Closed

Just tested on the same platform on 2.18.4, no crashes. Please reopen if necessary.

#3 Updated by Jürgen Fischer almost 3 years ago

  • Category set to Unknown

Also available in: Atom PDF