Bug report #15596

WMS layers cannot be identified on QGIS >= 2.16.*

Added by Giovanni Manghi about 3 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Web Services clients/WMS
Affected QGIS version:master_2 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23519

Description

On Linux (as Windows seems ok, OsX to be confirmed) and QGIS 2.16.* WMS layers from a Geonode/Geoserver service do not return any values when identified (in identify dialog a "loading..." text is presented).

On the same platform, with QGIS 2.14.* it works as exptected.

OS is Ubuntu 16.04 and QGIS is always installed from official repos (both ltr and 2.16).

I can provide privately details to access to the Geoserver service.

Associated revisions

Revision 59d1d702
Added by Martin Dobias almost 3 years ago

Fix identify tool for WMS if webkit is not available (fixes #15596)

(cherry picked from commit 430694ba9a2beb5fe23d5814b63aaecdbee7a3d7)

History

#1 Updated by Martin Dobias almost 3 years ago

  • Status changed from Open to Closed

Fixed in changeset 430694ba9a2beb5fe23d5814b63aaecdbee7a3d7 (the commit unfortunately references a different bug)

Also available in: Atom PDF