Bug report #15528

Incompatible matplotlib and pyparsing on Windows in QGIS 2.16.2

Added by Arnaud Morvan about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:2.16.2 Regression?:No
Operating System:MS Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:23452

Description

It seems that the pyparsing version (1.5.2) installed with QGIS 2.16.2 on Windows in :
C:/Programmes/QGIS 2.16/apps/Python27/Lib/sites-packages
is too old for the matplotlib one.
matplotlib says : "matplotlib requires pyparsing >= 1.5.6"

I've installed QGIS from that link : http://qgis.org/downloads/QGIS-OSGeo4W-2.16.2-2-Setup-x86.exe

Best Regards

Arnaud Morvan
Camptocamp

History

#1 Updated by Jürgen Fischer about 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Open to Closed

Already fixed in OSGeo4W

Also available in: Atom PDF