Bug report #15389

Raster | Miscellaneous | Build Virtual Raster produces "RuntimeError: wrapped C/C++ object of type QCheckBox has been deleted "

Added by Frank Bilki about 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Python plugins
Affected QGIS version:2.16.1 Regression?:No
Operating System:Linux Mint; Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:23319

Description

I am assembling Landsat images into multispectral files by building virtual rasters for each scene.

There is a certain combination of options on the Build Virtual Raster dialog that always produces an error. On two different Linux Mint 17.3 machines, QGIS displays the following error when I run the function:

An error has occurred while executing Python code:

RuntimeError: wrapped C/C++ object of type QCheckBox has been deleted 
Traceback (most recent call last):
  File "/usr/share/qgis/python/plugins/GdalTools/tools/doBuildVRT.py", line 110, in switchLayerMode
    enableInputFiles = not self.inputSelLayersCheck.isChecked()
RuntimeError: wrapped C/C++ object of type QCheckBox has been deleted

Python version: 2.7.6 (default, Jun 22 2015, 18:01:27) [GCC 4.8.2] 
QGIS version: 2.16.1-Nødebo Nødebo, 8545b3b 

Python Path:
/usr/share/qgis/python/plugins/processing
/usr/share/qgis/python
/home/xxx/.qgis2/python
/home/xxx/.qgis2/python/plugins
/usr/share/qgis/python/plugins
/usr/local/lib/python2.7/dist-packages/lidar2dems-1.1.0a1-py2.7.egg
/usr/local/lib/python2.7/dist-packages/Fiona-1.6.2-py2.7-linux-x86_64.egg
/usr/local/lib/python2.7/dist-packages/Shapely-1.5.12-py2.7-linux-x86_64.egg
/usr/local/lib/python2.7/dist-packages/click_plugins-1.0.2-py2.7.egg
/usr/local/lib/python2.7/dist-packages/cligj-0.3.0-py2.7.egg
/usr/local/lib/python2.7/dist-packages/click-5.1-py2.7.egg
/usr/lib/python2.7/dist-packages
/usr/lib/python2.7
/usr/lib/python2.7/plat-x86_64-linux-gnu
/usr/lib/python2.7/lib-tk
/usr/lib/python2.7/lib-old
/usr/lib/python2.7/lib-dynload
/usr/local/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages/PILcompat
/usr/lib/python2.7/dist-packages/gtk-2.0
/usr/lib/pymodules/python2.7
/usr/lib/python2.7/dist-packages/ubuntu-sso-client
/home/xxx/.qgis2//python

On Windows 10, QGIS crashes on exit, with a minidump (attached).

As far as I can tell, it was introduced in the .1 release, so it looks like a regression.

qgis-20160804-091426-3964-11100-8545b3b.7z (2.28 MB) Frank Bilki, 2016-08-03 09:44 PM

2016-08-04_12-32-17.png (22.9 KB) Frank Bilki, 2016-08-03 09:45 PM

Associated revisions

Revision e963fff3
Added by Jürgen Fischer almost 4 years ago

gdal tools: disconnect canvas signal after building vrt (fixes #15389)

Revision aa30c2fe
Added by Jürgen Fischer almost 4 years ago

gdal tools: disconnect canvas signal after building vrt (fixes #15389)

(cherry picked from commit e963fff346aafdb87494c9a33c4cddd3754ab5b1)

Revision c7b68166
Added by Jürgen Fischer almost 4 years ago

processing: disconnect canvas signal after building vrt (fixes #15389)

(cherry picked from commit e963fff346aafdb87494c9a33c4cddd3754ab5b1)

Revision dedf4a5a
Added by Jürgen Fischer almost 4 years ago

gdal tools: disconnect canvas signal after building vrt (fixes #15389)

(cherry picked from commit e963fff346aafdb87494c9a33c4cddd3754ab5b1)

History

#2 Updated by Frank Bilki about 4 years ago

Forgot to say that the attached screenshot shows the parameter values on the Virtual Raster dialog.

#3 Updated by Pedro Venâncio about 4 years ago

I confirm this error on QGIS 2.16.2 (Windows 10 - OSGeo4W 64 bits).

#4 Updated by Jürgen Fischer almost 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF