Bug report #15315

DB-Manager Import Double

Added by Mo Scott over 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:DB Manager
Affected QGIS version:2.16.0 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:23247

Description

The import of shapefiles containing double-values (might only be if Value >9) into a PostGis-DB fails under QGis version 2.16 on Ubuntu 14.04 although it is possible in version 2.14. I'm sorry I don't have the exact Error message (downgraded already) but it says something about numeric(19,18) can not contain values bigger 10. The Table is createt with the columns where there should be double specified to numeric(19,18). In Qgis 2.14 the same columns are createt as numeric without spesification.
Hope this helps and can be resolved.

qgisTest.zip (1.26 KB) Mo Scott, 2017-03-09 03:10 AM

History

#1 Updated by Goyo D over 4 years ago

It is true that numeric(19,18) can not contain values bigger than 10 so I do not think this is a bug.

#2 Updated by Goyo D over 4 years ago

Uh, sorry. I think I misunderstood the issue.

#3 Updated by Mo Scott over 4 years ago

Hi Goyo D,

yes, I'm sorry I was a bit unclear. I hope one can still understand the issue: it should be possible to import numeric values from a shapefile but it is not because the columns in the DB are initiated in the wrong format.
I am a bit concerned that this topic gets no attention because it made the plugin unusable for me and I had to downgrade. Does it really affect only me?

Greetings

#4 Updated by Giovanni Manghi almost 4 years ago

  • Priority changed from Normal to High

#5 Updated by Giovanni Manghi over 3 years ago

  • Priority changed from High to Normal
  • Crashes QGIS or corrupts data changed from Yes to No
  • Status changed from Open to Feedback

This would eventually configure as regression, especially if still confirmed on 2.18.4

Can you please attach sample data? Thanks.

#6 Updated by Giovanni Manghi over 3 years ago

  • Priority changed from Normal to Severe/Regression

#7 Updated by Mo Scott over 3 years ago

I'm sorry, I neither have a Postgis-DB nor a QGIS-Installation version higher 2.14 at hand to do some testing. As this thread is older, also the Data that created the bug is gone.
But I have created a sampledataset that should be be capable of creating the error, if it still exists. I hope it will help.
Greetings

#8 Updated by Giovanni Manghi over 3 years ago

Mo Scott wrote:

I'm sorry, I neither have a Postgis-DB nor a QGIS-Installation version higher 2.14 at hand to do some testing. As this thread is older, also the Data that created the bug is gone.
But I have created a sampledataset that should be be capable of creating the error, if it still exists. I hope it will help.
Greetings

thanks, I will have a lot at it.

#9 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

Tested on 2.18.7, no errors.

Also available in: Atom PDF