Bug report #15307

QGis installation fails on ubuntu 14.04

Added by Hendrik Huyskens almost 3 years ago. Updated over 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:2.16.0 Regression?:No
Operating System:Ubuntu Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:23239

Description

Until yesterday my whole qgis and python-qgis worked fine with version 2.14 under Ubuntu 14.04.
After a simple `sudo apt-get update` and `sudo apt-get upgrade` qgis failed to update...
Several attempts to reinstall it with different versions failed.
Current error message (for version 2.14.3) goes like this:

qgis-providers (2.14.3+dfsg-2~trusty1) is configured ...
/usr/lib/qgis/crssync: symbol lookup error: /usr/lib/libgdal.so.20: undefined symbol: GEOSDelaunayTriangulation_r

And for version 2.16.0 it is:

/usr/lib/qgis/crssync: symbol lookup error: /usr/lib/libqgis_core.so.2.16.0: undefined symbol: GEOSNearestPoints_r

Tried to reinstall all gdal libraries - not sure if I got all?!
I also posted this bug to stackoverflow for any help: http://gis.stackexchange.com/questions/202674/qgis-update-failed

Thanks for help or any suggestions!

History

#1 Updated by Lukas Krieger almost 3 years ago

Just wanted to second this issue.

I had qgis 2.16 installed and working with ubuntugis-unstable on trusty. After an update I had a conflict with python-mpltoolkits.basemap concerning the version of libgeos. I tried uninstalling every qdal and qgis related packages and perform a clean reinstall and now qgis-providers fails to install correctly with the same errors. I tied using the ubuntugis-unstable packages as well as the debian packages.

I am fairly certain that I managed to uninstall every conflicting package before trying to install. But maybe one slipped by.

Thanks for helping!

#2 Updated by Andre Joost over 2 years ago

  • % Done changed from 0 to 100
  • Target version changed from Version 2.16 to Version 2.18
  • Status changed from Open to Closed

Since QGIS 2.16 is now replaced by QGIS 2.18, I think the issue can be closed for now.

The error is not reproducible on QGIS 2.18.0 for me.

Reopen if necessary.

Also available in: Atom PDF