Bug report #15294

Node tool selects wrong features

Added by R. R. almost 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Digitising
Affected QGIS version:2.16.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23228

Description

Selecting a feature by clicking on it fails in some cases (see screencast).

15294_.mp4 (2.82 MB) R. R., 2016-07-17 12:36 AM

15294_2.zip - shape files #2 (6.91 KB) R. R., 2016-07-17 05:36 AM

15294_2.mp4 - screencast #2 (2.86 MB) R. R., 2016-07-17 05:36 AM

15294_3.mp4 - screencast #3 (993 KB) R. R., 2016-07-17 07:47 AM

Associated revisions

Revision 6b279941
Added by Jürgen Fischer over 3 years ago

nodetool: use exact intersect when picking features (fixes #15294)

Revision 2e284c81
Added by Jürgen Fischer over 3 years ago

nodetool: use exact intersect when picking features (fixes #15294)

(cherry picked from commit 6b2799414a3b6434818adc859d3f1363029eb579)

Revision ae76aa60
Added by Jürgen Fischer over 3 years ago

nodetool: use exact intersect when picking features (fixes #15294)

(cherry picked from commit 6b2799414a3b6434818adc859d3f1363029eb579)

Revision 30580ed1
Added by Jürgen Fischer over 3 years ago

nodetool: use exact intersect when picking features (fixes #15294)

(cherry picked from commit 6b2799414a3b6434818adc859d3f1363029eb579)

History

#1 Updated by R. R. almost 4 years ago

Related: #15075 (Node tool doesn't recognize polygon new extent until feature is saved)

#2 Updated by Giovanni Manghi almost 4 years ago

  • Status changed from Open to Feedback

Hi,

could you provide the dataset (or sample of) where is possible to replicate the issue shown in the video?

It seems also a different, not related issue compared to #15075

#3 Updated by R. R. almost 4 years ago

Please import the attached .shp file into a PostGIS database to reproduce the issue.

#4 Updated by R. R. almost 4 years ago

#5 Updated by R. R. almost 4 years ago

Hi Giovanni,

can you please change the status from 'Feedback' to 'Open'?

Giovanni Manghi wrote:

Hi,
It seems also a different, not related issue compared to #15075

In both cases selecting features using the node tool fails, but I don't know if this is caused by the same issue or not.

#6 Updated by Jürgen Fischer over 3 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF