Bug report #15237

QGIS 2.14.x Fedora 24/KDE ImportError: cannot import name QtWebKit

Added by Flo Ju about 4 years ago. Updated about 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Unknown
Affected QGIS version:2.14.3 Regression?:No
Operating System:Linux/Fedora Easy fix?:No
Pull Request or Patch supplied:No Resolution:up/downstream
Crashes QGIS or corrupts data:No Copied to github as #:23173

Description

Starting QGIS 2.14.x on Fedora 24 opens dialog with the following error.

Couldn't load plugin 'processing' 

ImportError: cannot import name QtWebKit 
Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/qgis/utils.py", line 281, in loadPlugin
    __import__(packageName)
  File "/usr/lib64/python2.7/site-packages/qgis/utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/flo/.qgis2/python/plugins/processing/__init__.py", line 29, in 
    from processing.tools.general import *
  File "/usr/lib64/python2.7/site-packages/qgis/utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/flo/.qgis2/python/plugins/processing/tools/general.py", line 28, in 
    from processing.core.Processing import Processing
  File "/usr/lib64/python2.7/site-packages/qgis/utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/flo/.qgis2/python/plugins/processing/core/Processing.py", line 43, in 
    from processing.gui.Postprocessing import handleAlgorithmResults
  File "/usr/lib64/python2.7/site-packages/qgis/utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/flo/.qgis2/python/plugins/processing/gui/Postprocessing.py", line 36, in 
    from processing.gui.ResultsDialog import ResultsDialog
  File "/usr/lib64/python2.7/site-packages/qgis/utils.py", line 572, in _import
    mod = _builtin_import(name, globals, locals, fromlist, level)
  File "/home/flo/.qgis2/python/plugins/processing/gui/ResultsDialog.py", line 38, in 
    os.path.join(pluginPath, 'ui', 'DlgResults.ui'))
  File "/usr/lib64/python2.7/site-packages/PyQt4/uic/__init__.py", line 211, in loadUiType
    exec(code_string.getvalue(), ui_globals)
  File "", line 52, in 
ImportError: cannot import name QtWebKit

Python version: 2.7.11 (default, Jun 21 2016, 09:15:12) [GCC 6.1.1 20160510 (Red Hat 6.1.1-2)] 
QGIS version: 2.14.3-Essen Essen, exported 

Python Path:
/usr/share/qgis/python
/home/flo/.qgis2/python
/home/flo/.qgis2/python/plugins
/usr/share/qgis/python/plugins
/usr/lib64/python27.zip
/usr/lib64/python2.7
/usr/lib64/python2.7/plat-linux2
/usr/lib64/python2.7/lib-tk
/usr/lib64/python2.7/lib-old
/usr/lib64/python2.7/lib-dynload
/usr/lib64/python2.7/site-packages
/usr/lib64/python2.7/site-packages/gtk-2.0
/usr/lib64/python2.7/site-packages/wx-3.0-gtk3
/usr/lib/python2.7/site-packages
/home/flo/.qgis2//python

History

#1 Updated by Flo Ju about 4 years ago

Looks like to be same problem as in Debian

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=828031

#2 Updated by Evan Rosenlieb about 4 years ago

Hello,

I have the exact same error. I would past the traceback and everything however it is essentially the exact same.

What seems very odd to me is that if I open python in the terminal ans "Import QtWebKit", it does so without direction, so it is properly added in my PYTHONPATH.

I also can see in the traceback that the specific folder is added that contains the QtWebKit.so module. Very strange...

In any case, I hope this gets fixed soon... Most of what I use Q for is contained in the processing panel!

#3 Updated by Jürgen Fischer about 4 years ago

Did you install PyQt4-webkit? In 2.14.4 processing doesn't require QtWebKit/WebView anymore.

#4 Updated by Flo Ju about 4 years ago

Hi! I used QGIS 2.14.x I think it is 2.14.3) for Fedora from the COPR-Repo (https://copr.fedorainfracloud.org/coprs/neteler/QGIS-2.14-Essen/)
and Yes, I post-installed pyqt4-webkit.

#5 Updated by Jürgen Fischer about 4 years ago

Flo Ju wrote:

Hi! I used QGIS 2.14.x I think it is 2.14.3) for Fedora from the COPR-Repo (https://copr.fedorainfracloud.org/coprs/neteler/QGIS-2.14-Essen/)
and Yes, I post-installed pyqt4-webkit.

Does this work on your machine?

$ python
Python 2.7.3 (default, Jun 21 2016, 18:38:19) 
[GCC 4.7.2] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> from PyQt4.QtWebKit import QWebView

#6 Updated by Flo Ju about 4 years ago

Can't test it at the moment - because of the issue I downgraded again to F23. I will test it in a few days in a virtualized Fedora 24/KDE environment.

#7 Updated by Flo Ju about 4 years ago

Update: Fresh install from the orig. Fedora 24 repo (2.14.3 QGIS) on F24/xfce (virtualized). Reports at startup: Konnte Erweiterung 'processing' nicht laden
ImportError: No module named pyspatialite

So, no Porcessing-tools too - this looks like missing pyspatialite is not installed by default via Python PIP with the QGIS installation.

Installing pyspatialite with CFLAGS=-I/usr/include pip install pyspatialite also reports an error in Python PIP. I will have a look on it.
But QGIS with it's dependencies does not seem to be distributed well in F24.

#8 Updated by Jürgen Fischer about 4 years ago

Flo Ju wrote:

Installing pyspatialite with CFLAGS=-I/usr/include pip install pyspatialite also reports an error in Python PIP. I will have a look on it.
But QGIS with it's dependencies does not seem to be distributed well in F24.

But it looks like packaging problems and not original QGIS issues.

#9 Updated by Flo Ju about 4 years ago

The pyspatialite-issue Yes :-/ ... should be solved by https://bugzilla.redhat.com/show_bug.cgi?id=1340535

After solving the pyspatialite-issue I had to install PyQt4-webkit-4.11.4-14.fc24 manually and now it looks like QGIS 2.14.3 from the Fedora-Repo works with Processing (will do some tests later).

All in all package-dependencies are not OK at all. The user does not get a working QGIS 2.14 out of the box from the dnf-repo.

I will forward this issue to the Fedora-Team.

#10 Updated by Evan Rosenlieb about 4 years ago

Thanks so much guys, installed PyQt4-webkit fixed the problem for me as well.

#11 Updated by Jürgen Fischer about 4 years ago

  • Status changed from Open to Closed
  • Resolution set to up/downstream

#12 Updated by Evan Rosenlieb about 4 years ago

Flo, let me know if you need any help with the bug report for the Fedora folks.

#13 Updated by Flo Ju about 4 years ago

Hi Evan! That would be nice if you directly know where and how to report it - I think there are 2 things to do:
A QGIS 2.14.2 from the F24-Repo is not fully usable and reports a startup-error because:
1) the missing pyspatialite dependency(--> Python PIP) and that can not be done because of the known issue https://bugzilla.redhat.com/show_bug.cgi?id=1340535
2) the missing PyQt4-webkit

Beside the official repo for F24 the COPR-Repo should also be addressed https://copr.fedorainfracloud.org/coprs/neteler/QGIS-2.14-Essen/

The next days I will again do a test-run on a clean F24.

#14 Updated by Jürgen Fischer about 3 years ago

  • Category set to Unknown

Also available in: Atom PDF