Bug report #15236

'Check geometries' plugin fails to fix sliver polygons when 'Output vector layer' is set to 'Create new layer'

Added by R. R. over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:Sandro Mani
Category:C++ plugins/Geometry Checker
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23172

Description

Here the sliver polygon check fails with an exception when 'Output vector layer' is set to 'Create new layer'.

'Exception: normalized vector of null vector undefined'

normalized_vector_of_null_vector_undefined.png (68.2 KB) R. R., 2016-07-07 09:03 AM

15236_exception.zip - shape file (3.78 KB) R. R., 2016-07-10 11:47 AM

15236_exception.mp4 - screencast (1.08 MB) R. R., 2016-07-10 11:47 AM

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Open to Feedback

Is possible to attach same sample data? thanks.

#2 Updated by R. R. over 4 years ago

Unfortunately, I can not attach the geometries due to the proprietary nature of the file.

#3 Updated by R. R. over 4 years ago

The minimal polygon area check may throw the same exception (see attached files).

#4 Updated by Sandro Mani over 4 years ago

  • Status changed from Feedback to Closed

Fixed in 046386e

Also available in: Atom PDF