Bug report #15231

Crash when right-click on geometry-less layer

Added by Daan Goedkoop about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:GUI
Affected QGIS version:2.14.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:Yes Resolution:
Crashes QGIS or corrupts data:Yes Copied to github as #:23167

Description

Affected is the current version of the release-2_14 branch (as of writing this, commit 0fc21a8).

It is fixed in master:

054604b fix crash when right-clicking on geometryless layers

This commit should probably be back-ported before the 2.14.4 release.

History

#1 Updated by Andreas Neumann about 4 years ago

  • Affected QGIS version changed from master to 2.14.3

Changing this to 2.14.x - since master isn't affected.

#2 Updated by Daan Goedkoop about 4 years ago

  • Status changed from Open to Closed

Fix in commit c2fe260 seems to work. Thanks!

Also available in: Atom PDF