Feature request #15166

Cannot reach top of tree in Layers Panel

Added by Dan Jacobson over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:GUI
Pull Request or Patch supplied:No Resolution:wontfix
Easy fix?:No Copied to github as #:23105

Description

In computer science, every tree has a root node.
Alas in Layers Panel it is cut off, we can't scroll up to see it and manipulate it.

y.jpg (9.69 KB) Dan Jacobson, 2016-06-28 07:29 PM

History

#1 Updated by Andreas Neumann over 4 years ago

Hi Dan,

Can you be more descriptive about what you would like to do with the root node? Provide some use cases?

And how should it look like in the UI?

Andreas

#2 Updated by Martin Dobias over 4 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

This is by design in the Qt model/view framework for the tree view and it is how all tree views in Qt work (in fact there is actually a root node that is always invisible).

If you need to have a top-level node in your project, I would suggest adding a top-level group and moving everything else into that group.

Also available in: Atom PDF