Bug report #1515

wms layer is added even if the the request fails

Added by Giovanni Manghi over 10 years ago. Updated about 10 years ago.

Status:Closed
Priority:Low
Assignee:Marco Hugentobler
Category:Web Services clients/WMS
Affected QGIS version: Regression?:No
Operating System:All Easy fix?:No
Pull Request or Patch supplied: Resolution:wontfix
Crashes QGIS or corrupts data: Copied to github as #:11575

Description

When a WMS layer is added and the requests fails, the layer is added anyway in the legend. The result is that if the layer is not removed by hand from the legend, any action (zoom, pan, add/remove other layers) will produce the error shown when the initial request failed.

If the wms layer cannot be retrieved it should not be added to the legend.

I noticed this behavior when I mistakenly used the wrong URL while adding a new wms server connection:

I used

http://mapas.igeo.pt/igp/Capabilities/wms_CRIF_GetCapabilities.xml

instead of

http://mapas.igeo.pt/wms/crif2008

The first URL gives a list of layers but a error is returned when you try to add them, still they are added to the legend.

History

#1 Updated by Giovanni Manghi about 10 years ago

  • Resolution set to wontfix
  • Status changed from Open to Closed

Well, the problem was then explained very bad. I will open a new ticket with a better description if and when I will encounter again the same problem.

Also available in: Atom PDF