Bug report #15138

WMS 1.1.1 doesn't work in master

Added by dr - about 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:23077

Description

Trying to add WMS layer from server http://bushman.nextgis.com/api/resource/22/wms?VERSION=1.1.1

In QGIS 2.14 it works fine, but doesn't work in master.

Layer properties (master):

Layer Extent (layer original source projection)
-0.0016169675114151,-0.0007640272910986 : 0.0016169675114151,0.0007640272910986

Layer properties (2.14):

Layer Extent (layer original source projection))
-20037508.3427892439067364,-20037508.6269291006028652 : 20037508.3427892439067364,20037508.6269291080534458

wmsok.png - Ok in master? (465 KB) Richard Duivenvoorde, 2016-07-04 04:59 AM

History

#1 Updated by Richard Duivenvoorde about 4 years ago

It's working fine with me in current master, can you please retest and report back, or let us know a way to reproduce?

The legendimage is not ok due to 'bad gateway':

http://bushman.nextgis.com/api/resource/22/wms?SERVICE=WMS&VERSION=1.1.1&SLD_VERSION=1.1.0&REQUEST=GetLegendGraphic&FORMAT=image/png&LAYER=sentinel2_42sug&STYLE=&TRANSPARENT=true

First GetMap request that is fired with me:
http://bushman.nextgis.com/api/resource/22/wms?SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&BBOX=-20037508.34278924391,-20037508.6269291006,20037508.34278924391,20037508.62692910805&SRS=EPSG:3857&WIDTH=631&HEIGHT=632&LAYERS=sentinel2_42sug&STYLES=&FORMAT=image/png&DPI=96&MAP_RESOLUTION=96&FORMAT_OPTIONS=dpi:96&TRANSPARENT=TRUE

So I have to zoom in a lot.

It looks like there is some latlong-swapping going on? Maybe related to 0409f5e

But as said, at least I get an image (and it is the full world that is advertised as the layer extent:

http://bushman.nextgis.com/api/resource/22/wms?SERVICE=WMS&VERSION=1.3.0&REQUEST=GetCapabilities

#2 Updated by Richard Duivenvoorde about 4 years ago

  • Status changed from Open to Feedback

#3 Updated by dr - about 4 years ago

  • Resolution set to fixed/implemented
  • Status changed from Feedback to Closed

Thanks for help. It looks like issue was already fixed, now all works as expected.

#4 Updated by Jürgen Fischer almost 3 years ago

  • Category set to Unknown

Also available in: Atom PDF