Bug report #15105

Problem with handling Plugin layers style

Added by Saber Razmjooei over 4 years ago. Updated almost 2 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Symbology
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:23047

Description

With QGIS master, when loading a plugin layer (Crayfish in my case) I get the following error:

NotImplementedError: QgsPluginLayer.writeStyle() is abstract and must be overridden 

Python version: 2.7.6 (default, Jun 22 2015, 18:01:27) [GCC 4.8.2] 
QGIS version: 2.15.0-Master Master, f645b79

This is likely to be due to the new dock style manager.

History

#1 Updated by Giovanni Manghi over 3 years ago

  • Easy fix? set to No
  • Regression? set to No

#2 Updated by Saber Razmjooei almost 2 years ago

  • Status changed from Open to Closed
  • Description updated (diff)

Also available in: Atom PDF