Bug report #15044

Topology checker fails to highlight a listed overlap between polygon shapefile layers.

Added by Steve Lowman over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:C++ plugins/Topology checker
Affected QGIS version:2.14.3 Regression?:No
Operating System:Windows 10 Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22989

Description

Attached are three polygon/multipolygon shapefiles: Layer_A; Layer_B_withError; Layer_B_withErrorFixed.
There is only one difference between the 'withError' and'withErrorFixed' features, which is a single vertex location.
This vertex in the 'withError' features is snapped to a 'Layer_A' vertex.
It is moved away from the 'Layer_A' feature in the 'withErrorFixed' features.
The vertex of interest is in the vicinity of the coordinates: 334290,613790

To reproduce the error, and see the difference with the 'fixed' version, do the following:
1. Add all three shapefiles as new layers.
2. Give each layer a different colour style, and best give them some transparency.
3. Open Topology Checker.
4. To see the error, add and run the rule: "Layer_A must not overlap with Layer_B_withError", and check 'Show Errors'.
5. You should see three (3) overlaps listed, but only two (2) of the overlapping areas are highlighted in red.
6. If you then change the rule to "Layer_A must not overlap with Layer_B_withErrorFixed", you should see all three (3) overlaps are highlighted.
7. If you zoom into the coordinates 334290,613790, and show both of the Layer_B layers, you should see the difference in the vertex location, as mentioned above.

This is tested in 2.14.3, but not yet in Master.
The bug seems similar but probably not the same as the one in Bug report #10748. This one should be easier to pin down, though.

TopologyCheckerHighlightError.zip (18.7 KB) Steve Lowman, 2016-06-16 07:06 AM

History

#1 Updated by Steve Lowman over 4 years ago

  • Status changed from Open to Closed

Changed status to 'Closed', because this is an unintentional duplicate of #15043.

Also available in: Atom PDF