Bug report #15034

regression: renaming non-project bookmarks (partially) broken

Added by Mathieu Pellerin - nIRV over 3 years ago. Updated about 3 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Map Tools
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22981

Description

Since this 11a5a69, renaming newly-added non-project bookmarks (via double-clicking on the list' name column) fails when bookmark list is empty.

Steps to reproduce
1. Open the bookmarks panel, making sure there are no bookmarks (export your list and clear it temporarily if needed)
2. Add a new bookmark, renamed it
3. Notice the name doesn't stick, reverts to "New bookmark"

Associated revisions

Revision 4746158a
Added by Mathieu Pellerin - nIRV over 3 years ago

fix bookmarks editing regression (fixes #15034) (#3204)

History

#1 Updated by Mathieu Pellerin - nIRV over 3 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF