Bug report #14995

Missing texts in dxf export

Added by Richard McDonnell over 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:Normal
Assignee:Jürgen Fischer
Category:DXF export
Affected QGIS version:2.14.3 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:22942

Description

I would firstly like to say that the DXF Export option is great, and is a great addition to QGIS.
There is one problem though which you you may be able to help with.

I have a PostGIS database LineStrings and Points (Text) The Linestrings come out perfect, the problem is the text.
What I would like to do is have the text export also, all I get when I export the point file is....Points, no text.
I would appreciate any help, I am tying to get a Map out at the moment and would have a preference to output it via QGIS.

I have attached a zip file with two shapefiles, exported from the PostGIS database, I have had to restyle them, due to database column headers being longer than shapefiles.
The included QGIS Project File contains everything styled as I would the PostGIS database.
Regards,

Richard.

Bug_Report_Sample_Data.zip - Zip file containing sample Data and project. (447 KB) Richard McDonnell, 2016-06-10 04:42 AM

Associated revisions

Revision f470dfb0
Added by Jürgen Fischer about 4 years ago

dxf export: don't use 3D coordinates for filled circles (followup b3bf4a1; refs #14995)

History

#1 Updated by Jürgen Fischer over 4 years ago

  • Subject changed from QGIS DXF Export Bug to Missing texts in dxf export

#2 Updated by Jürgen Fischer about 4 years ago

I can't reproduce this - works fine with AutoCAD for me. But I found a problem using BricsCAD, which would reject the filled circles as invalid, because of 3D coordinates. Perhaps that also caused problems with the software you use. I suppose you used a symbology scale within the visiblity range of the point layer...

#3 Updated by Giovanni Manghi about 4 years ago

  • Status changed from Open to Feedback

#4 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to not reproducable

Jürgen Fischer wrote:

I can't reproduce this

Closing for lack of feedback, please reopen if necessary.

#5 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Feedback to Closed

Also available in: Atom PDF