Bug report #14873

attribute table sorting fails on column named "YEAR"

Added by Mathieu Pellerin - nIRV about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Severe/Regression
Assignee:-
Category:Attribute table
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22826

Description

The attribute table sorting fails when clicking on a column named "YEAR". The same dataset with a renamed column, for e.g. "NOYEAR", will successfully sort the table.

Steps to reproduce
  1. Create a new project, add the following dataset (http://www.licadho-cambodia.org/land_concessions/data/licadho-land-concessions-2015.zip)
  2. Open the attribute table
  3. To test that sorting is working, click on the NAME column
  4. Now click on the YEAR column, and notice the absence of sorting :)

Associated revisions

Revision 38e9435d
Added by Mathieu Pellerin - nIRV about 4 years ago

[attributetable] add quotes to column name when sorting (fixes #14873)

Revision 1b905c81
Added by Matthias Kuhn about 4 years ago

Merge pull request #3165 from nirvn/fix_attributetable_sort

[attributetable] add quotes to column name when sorting (fixes #14873)

History

#1 Updated by Giovanni Manghi about 4 years ago

reserved word?

#2 Updated by manelclos - about 4 years ago

Works for me using "steps to reproduce".

#3 Updated by Anonymous about 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF