Bug report #14816

no style backward compatibility

Added by Andre Jesus almost 4 years ago. Updated about 1 year ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:2.8.9 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:end of life
Crashes QGIS or corrupts data:No Copied to github as #:22771

Description

2.8.7 and prior versions
1. Create a style for a vector layer
2. Set style as default

2.8.9 onward
1. copy qgis.qmldb file (2.8.7 -) to 2.8.9+
2. Open same vector layer, no style has been applied

==================

2.8.7 and prior versions
1. Create a style for a vector layer
2. Save QGIS project

2.8.9 onward
1. Open QGIS project (style loaded fine)
2. Set style as deafult
3. Reopen QGIS: style not loaded

================== ==================

So I can only set default styles in QGIS 2.8.9 if I create them in the current version

2.8.9 onward
1. Create a style for a vector layer
2. Set style as default
3. Reopen QGIS and load the vector
4. Default style loaded

==================

I have to say, recreate styles for 150 layers will be a pain....

History

#1 Updated by Andre Jesus almost 4 years ago

copying a QMLDB file made in a 2.14.3 QGIS to another 2.14.3 QGIS also does not work

#2 Updated by Jürgen Fischer almost 4 years ago

  • Subject changed from no style backward compatibily to no style backward compatibility

#3 Updated by Jürgen Fischer almost 4 years ago

  • Category set to Project Loading/Saving

#4 Updated by Giovanni Manghi almost 3 years ago

  • Regression? set to No
  • Easy fix? set to No

#5 Updated by Giovanni Manghi about 1 year ago

  • Resolution set to end of life
  • Status changed from Open to Closed

Also available in: Atom PDF