Bug report #14787

API documentation browsing regression

Added by Thomas Gratier about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Documentation and Help
Affected QGIS version:2.12.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22744

Description

Symptom:

=> It's not working.

Technical issue

The technical issue is related to a missing jquery.js file (issue tried for 2.12, 2.14 and master API documentation).

To confirm, open a browser and use included Developer Tools debugger from the browser.

Now, visit the following URLs:

The fist one does not send and error in the browser debugger console whereas the others return a message about "ReferenceError: $ is not defined".
It's only the symptom for a missing jQuery file.

You get 404 errors for http://qgis.org/api/2.12/jquery.js, http://qgis.org/api/2.14/jquery.js and http://qgis.org/api/jquery.js whereas the file is available at http://qgis.org/api/2.10/jquery.js

It's clearly a regression concerning the API documentation build since 2.12.

I suppose it's related to the Doxygen version and/or the API documentation build process.

History

#1 Updated by Thomas Gratier about 4 years ago

  • % Done changed from 0 to 100
  • Status changed from Open to Closed

Solve by Jurgen Fischer

Also available in: Atom PDF