Bug report #14774

Import CSV returns incorrect table

Added by Stephen Knox about 4 years ago. Updated almost 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Unknown
Affected QGIS version:master Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:No Copied to github as #:22731

Description

When using master version ca74cc0 the import CSV does not function correctly and gives a table with columns named UID then rows with individual numbers in every column (presumably UID). This is using the without geometry option, I have not tested other options.

Reverting back to version 2.14.2 everything works as expected, with the same settings.


Related issues

Duplicates QGIS Application - Bug report #14766: Attribute table broken (duplicated fields) in master Closed 2016-05-04

Associated revisions

Revision ffcf655b
Added by Matthias Kuhn about 4 years ago

Don't always show first column in attribute table

Add tests for some basic attribute table functionality

Fix #14774
Fix #14765
Fix #14766

History

#1 Updated by Richard Duivenvoorde about 4 years ago

I think this is all related to #14766

so probably this one can be closed as a duplicate of that one?

#2 Updated by Jürgen Fischer about 4 years ago

  • Resolution set to duplicate
  • Status changed from Open to Closed

#3 Updated by Jürgen Fischer almost 3 years ago

  • Category set to Unknown

Also available in: Atom PDF