Bug report #14731

Project file data loss

Added by Magnus Nilsson about 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Project Loading/Saving
Affected QGIS version:2.14.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:22689

Description

Hi
When opening a .qgs file used yesterday, I noticed that the project had lost almost all of the data, such as linked SHP-files. I have lost a few hours of work due to this and this is a bit worrying for further work. It is this first time I observe this and I am the only one working with the project file.

QGIS 2.14.0, 64 bit
Windows 7, 64 bit

Stationskarta_översikt.qgs (226 KB) Magnus Nilsson, 2016-04-26 10:58 PM


Related issues

Related to QGIS Application - Feature request #14460: Avoid corrupted qgs files when writing to network drives Open 2016-03-11

History

#1 Updated by Jürgen Fischer about 4 years ago

  • Status changed from Open to Feedback
  • Priority changed from High to Normal

Include information about what you did different this time or other steps to reproduce.

#2 Updated by Magnus Nilsson about 4 years ago

I wish I could provide steps to reproduce, but I think that will be hard. Yesterday, I experimented a bit with different parts of QGIS, such as creating a new virtual layer, Processing-Intersection, GroupStats and so on. I have not used these tools much before yesterday, not sure if one of these was the cause of the data loss.

#3 Updated by Magnus Nilsson about 4 years ago

This might be related to virtual layers, since at least one more user reported this problem in a project using virtual layers, https://lists.osgeo.org/pipermail/qgis-user/2016-April/036146.html.

#4 Updated by Magnus Nilsson about 4 years ago

Example of a broken project file attached.

#5 Updated by Giovanni Manghi about 4 years ago

  • Category set to Project Loading/Saving
  • Priority changed from Normal to High

Thanks for the project, but I'm not sure ow this can help troubleshooting this issue.
If you find a clear way to replicate please let us know.

#6 Updated by Matthias Kuhn about 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

It is impossible to fix this issue with the information provided in this report.

If you have additional information that will help to reproduce/fix this problem, please reopen this issue.

Thank you for reporting and sorry that we can not help.

Also available in: Atom PDF