Bug report #14668

GRASS Plugin: error deleting vector file

Added by Roy Roge over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:GRASS
Affected QGIS version:2.14.1 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:
Crashes QGIS or corrupts data:No Copied to github as #:22632

Description

If you load a vector layer from GRASS DB in QGIS Layers Panel,
then you remove it from the panel, still it is impossible to
delete the vector from GRASS DB using the Browser Panel delete function.

Step to reproduce:

- Load a vector file in a GRASS mapset using v.in.ogr,
- press View output to load the vector in QGIS,
- remove the vector from QGIS Layers Panel
- In the Browser panel right click the vector and choose "delete"

the vector file is not deleted and the geometry is corrupted
making the file unusable

Associated revisions

Revision bbaef371
Added by Radim Blazek over 4 years ago

[GRASS] close vector map if no more users, fixes #14668

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Open to Feedback

I cannot confirm using QGIS master on linux.

#2 Updated by Roy Roge over 4 years ago

I just tested and the problem persist on master

with:

QGIS 2.15.0 Master 0f048b5

OSGEO4W 64 bit on windows

GRASS 7.0.3 GRASS Plugin

maybe the issue is only on windows ?

#3 Updated by Radim Blazek over 4 years ago

  • Status changed from Feedback to Closed

#4 Updated by Radim Blazek over 4 years ago

In fact, close map code was commented, which resulted in keeping the file open and impossibility to delete the vector on Windows.

I have re-enabled closing map. There was a comment about possible dead-lock, but that was from early stages of the provider overhaul, so I hope it is OK now.

Also available in: Atom PDF