Bug report #14625

Do not install in Linux Mint

Added by Jek Volodin over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:Normal
Assignee:-
Category:Build/Install
Affected QGIS version:2.14.0 Regression?:No
Operating System:Linux Mint Easy fix?:No
Pull Request or Patch supplied:No Resolution:invalid
Crashes QGIS or corrupts data:No Copied to github as #:22590

Description

The repositories wit the latest release for Debian jessie add:

And authentication key too:

But attempt to install QGIS 2.14 with command
sudo apt-get install qgis python-qgis qgis-plugin-grass
ends with error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 python-qgis : Depends: python-qgis-common (= 1:2.14.1+13jessie) but it is not going to be installed
               Depends: libqgispython2.14.1 but it is not going to be installed
               Depends: libqgis-analysis2.14.1 but it is not going to be installed
               Depends: libqgis-core2.14.1 but it is not going to be installed
               Depends: libqgis-gui2.14.1 but it is not going to be installed
               Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
               Depends: libqgis-server2.14.1 but it is not going to be installed
               Depends: libstdc++6 (>= 4.9) but 4.8.4-2ubuntu1~14.04.1 is to be installed
               Depends: sip-api-11.1 but it is not installable
 qgis : Depends: libqgis-analysis2.14.1 but it is not going to be installed
        Depends: libqgis-app2.14.1 but it is not going to be installed
        Depends: libqgis-core2.14.1 but it is not going to be installed
        Depends: libqgis-gui2.14.1 but it is not going to be installed
        Depends: libqgis-networkanalysis2.14.1 but it is not going to be installed
        Depends: libstdc++6 (>= 4.9) but 4.8.4-2ubuntu1~14.04.1 is to be installed
        Depends: qgis-providers (= 1:2.14.1+13jessie) but it is not going to be installed
 qgis-plugin-grass : Depends: qgis-provider-grass (= 1:2.14.1+13jessie) but it is not going to be installed
                     Depends: libqgis-analysis2.14.1 but it is not going to be installed
                     Depends: libqgis-app2.14.1 but it is not going to be installed
                     Depends: libqgis-core2.14.1 but it is not going to be installed
                     Depends: libqgis-gui2.14.1 but it is not going to be installed
                     Depends: libqgisgrass6-2.14.1 but it is not going to be installed
                     Depends: libstdc++6 (>= 4.9) but 4.8.4-2ubuntu1~14.04.1 is to be installed
E: Unable to correct problems, you have held broken packages.

This error repeat at two different machines with different architecture (x86 and amd64)

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to invalid
  • Status changed from Open to Closed

wrong codename, on Mint you must use the Ubuntu ones, in this case "trusty".

Also available in: Atom PDF