Bug report #14617

unable to display data from GRASS read-only mapset

Added by Martin Landa over 4 years ago. Updated about 4 years ago.

Status:Closed
Priority:Normal
Assignee:Radim Blazek
Category:GRASS
Affected QGIS version:2.14.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:No Copied to github as #:22583

Description

The QGIS browser fails reading maps from GRASS read-only mapsets. The browser is trying to create in mapset directory for temporary data. Is it really needed? This feature is very limiting since you can browse (display) only data from mapsets where you have write permission.

Unable to make mapset element .tmp/c50

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Target version deleted (Version 2.16)

#2 Updated by Radim Blazek over 4 years ago

  • Assignee set to Radim Blazek

Which data type, raster or vector? Local or mounted drive? Unix or Windows?

I cannot reproduce it. I can read rasters/vectors from a mapset which has all dirs and files read only.

The error is result of call to G_make_mapset_element_tmp() but the provider does not call that function and I am not aware that it would be creating temporary files.

Could it be that GRASS lib is trying to create a tmp file under certain circumstances?

Can you please help to narrow down where it comes from?

#3 Updated by Radim Blazek about 4 years ago

  • Status changed from Open to Feedback

#4 Updated by Giovanni Manghi about 4 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF