Bug report #14588

WIndows 7 freezes when using 'Pick color' tool

Added by R. R. over 4 years ago. Updated over 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:GUI
Affected QGIS version:2.14.4 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:22556

Description

After updating QGIS from 2.14.0 to 2.14.1 (OSGeo) Windows 7 freezes when using the 'Pick color' tool in the 'Layer Properties' dialogue. I don't have any issues on my Ubuntu 14.04 LTS notebook.

pick_color.png (93.9 KB) R. R., 2016-04-05 03:21 AM

History

#1 Updated by R. R. over 4 years ago

  • Status changed from Open to Closed

I can't reproduce the bug. Maybe it's a scratch layer issue. I haven't done any updates or changes.

#2 Updated by Andre Jesus over 4 years ago

I can confirm this. It happened to me twice but It's random.
You click Pick Color tool and the whole Windows screen freezes, If you go to CTRL + ALT + DEL screen and come back screen comes back to normal.
This happens anywhere you use Pick Color.

#3 Updated by R. R. over 4 years ago

Hi Andre, thanks for your reply. I've just noticed that the preview in the 'Layer Properties' dialogue isn't working when picking a color. Maybe the issues are related.

#4 Updated by Giovanni Manghi over 4 years ago

  • Category set to GUI
  • Status changed from Reopened to Feedback

it is a blocker if it is a regression, do you confirm that this happens in specific release (onwards) but not before?

#5 Updated by R. R. over 4 years ago

The issue occurred after installing QGIS 2.14.1, but at the moment Windows isn't freezing when picking a color. So I'm not sure if it's a regression.

#6 Updated by Giovanni Manghi over 4 years ago

  • Priority changed from Severe/Regression to Normal

Reinhard Reiterer wrote:

but at the moment Windows isn't freezing when picking a color.

so right now the issue is not even confirmed, right?

#7 Updated by Giovanni Manghi over 4 years ago

  • Status changed from Feedback to Closed
  • Resolution set to worksforme

closing for lack of feedback, please reopen if necessary.

#8 Updated by Philip Tait over 4 years ago

  • Status changed from Closed to Reopened

Hi. I recently updated QGIS from 2.14.0 to 2.14.3 and this problem is happening to me. I load a shapefile. open the style properties, select pick color from the drop down next to the fill colour. Instead of getting the pippet cursor, the entire desktop freezes. Strangley, wherever I've clicked the colour is selected. however it is only updated once I've ctrl+alt+del to refresh. This has happened every time I try

#9 Updated by Andre Jesus over 4 years ago

Confirmed in 2.14.4 and 2.16.0 too (Windows 10)

#10 Updated by Giovanni Manghi over 4 years ago

  • Resolution deleted (worksforme)

#11 Updated by Giovanni Manghi over 3 years ago

  • Priority changed from Normal to High

#12 Updated by Giovanni Manghi over 3 years ago

  • Affected QGIS version changed from master to 2.14.4
  • Status changed from Reopened to Feedback

Andre Jesus wrote:

Confirmed in 2.14.4 and 2.16.0 too (Windows 10)

Cannot confirm on 2.18.4 on Windows or Linux. Please leave further feedback.

#13 Updated by Giovanni Manghi over 3 years ago

  • Status changed from Feedback to Closed
  • Resolution set to not reproducable

Closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF