Bug report #14550

crashes when invalid geojson files are in a directory

Added by Daniel Hogg over 3 years ago. Updated over 3 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Vectors
Affected QGIS version:2.12.3 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:not reproducable
Crashes QGIS or corrupts data:Yes Copied to github as #:22523

Description

I have had to reinstall the QGIS client because of this issue. What happened was I had some malformed .geojson files generated by a script on my server, which were then stored in a folder. When QGIS tries to open this folder to view the files, it crashes. From this point on, it crashes on startup, because the last thing it was doing was opening that folder, so it attempts to do it again.

When it crashes, it creates a 26MB .dmp file. Unfortunately, it is too large to be attached here. If someone considers it essential to have the .dmp file, I can be reached at .

History

#1 Updated by Jürgen Fischer over 3 years ago

  • Subject changed from QGIS 2.12.3-1 crashes when invalid geojson files are in a directory to crashes when invalid geojson files are in a directory

#2 Updated by Giovanni Manghi over 3 years ago

  • Crashes QGIS or corrupts data changed from No to Yes
  • OS version deleted (2.12.3-1)
  • Operating System deleted (QGIS Lyon)
  • Target version set to Future Release - High Priority
  • Status changed from Open to Feedback
  • Category set to Vectors
  • Priority changed from Normal to High

Please attach a sample of this problematic files.

#3 Updated by Giovanni Manghi over 3 years ago

  • Resolution set to not reproducable
  • Status changed from Feedback to Closed

closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF