Bug report #14509

Processing/SAGA: Union freezes program

Added by Mattias Lindman about 4 years ago. Updated almost 4 years ago.

Status:Closed
Priority:Normal
Assignee:Victor Olaya
Category:Processing/SAGA
Affected QGIS version:2.12.3 Regression?:No
Operating System:Windows 8 Easy fix?:No
Pull Request or Patch supplied:No Resolution:worksforme
Crashes QGIS or corrupts data:No Copied to github as #:22482

Description

When trying to use the Union and Intersect tools in the SAGA toolbox the following error message is given:

Can't load requested DLL: .....\\gdal_MrSID.dll
127: It is not possible to find the specified procedure (translated from Swedish)

I have checked and gdal_MrSid.dll is where it should be according to the path given in the error message. The intersect tool finishes and gives a result while the Union tool does not (and the program freezes).

I have tried both QGIS 2.8.7. and 2.12.4 in Windows 8.

History

#1 Updated by Jürgen Fischer about 4 years ago

This due to the unfortunate situation, that saga in osgeo4w is repackaged from binaries saga ships and those contain a different version of GDAL. You can just remove that DLL if you don't need MrSID data.

#2 Updated by Giovanni Manghi almost 4 years ago

  • Status changed from Open to Feedback
  • Subject changed from Saga toolbox: Union and Intersect tools to Processing/SAGA: Union freezes program

Now that we know that the error message about gdal_MrSid.dll is unrelated, let's focus on the operation that does not work.

first of all, the union you are trying to do does work on native SAGA?

If yes then please attach sample data to allow us replicate the issue locally. Thanks

#3 Updated by Giovanni Manghi almost 4 years ago

  • Resolution set to worksforme
  • Status changed from Feedback to Closed

closing for lack of feedback, please reopen if necessary.

Also available in: Atom PDF