Bug report #1450

Adding the Attribute Table DockWidget doesn't update canvas extent

Added by Borys Jurgiel almost 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:nobody -
Category:Map Canvas
Affected QGIS version: Regression?:No
Operating System:Debian Easy fix?:No
Pull Request or Patch supplied: Resolution:fixed
Crashes QGIS or corrupts data: Copied to github as #:11510

Description

When opening the attribute table as a DockWidget, the map canvas is not being refreshed, so whole contents disappears. Then if I refresh it or zoom, it's back, but the canvas extent is not updated - it still includes the area occupied by the table now. As a result, zoomToFullExtent hides a part of contents 'behind' the attribute table widget. I can't find what mathod should be called to update the extents.

QgsMapCanvas::extent() returns old values
QgsMapCanvas::zoomToFullExtent() zooms to this old (too extensive) extent
QgsMapCanvas::updateFullExtent() doesn't change anything
QgsMapCanvas::adjustSize() helps, but creates artifacts

Note that if I touch the window layout, for example resize any dock or whole main window, the canvas extent becomes updated and everything begins to work properly.

I set the 'must fix for release', because it's just an ugly behaviour making a bad impression on users and probably something easy to fix.

Associated revisions

Revision 43bc6294
Added by Jürgen Fischer over 11 years ago

fix #1450

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision cb2a8b5b
Added by Jürgen Fischer over 11 years ago

fix #1450

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision a58032da
Added by Jürgen Fischer over 11 years ago

fix #1450 and #1382 again

git-svn-id: http://svn.osgeo.org/qgis/trunk/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

Revision 9305a5bf
Added by Jürgen Fischer over 11 years ago

fix #1450 and #1382 again

git-svn-id: http://svn.osgeo.org/qgis/[email protected] c8812cc2-4d05-0410-92ff-de0c093fc19c

History

#1 Updated by Jürgen Fischer over 11 years ago

  • Status changed from Open to Closed
  • Resolution set to fixed

fixed in cb2a8b5b (SVN r9920)

#2 Updated by Borys Jurgiel over 11 years ago

  • Resolution deleted (fixed)
  • Status changed from Closed to Feedback

It's only partially fixed. When opening the attribute table, the map doens't disappear anymore (thanks), but is still covered by the table. The 'Update to full extent' button doesn't help. The map extent still contain the area covered by the table. But if you touch the window layout, the extent is immediatelly updated and the map is zoomed out.

#3 Updated by Jürgen Fischer over 11 years ago

Replying to [comment:2 borysiasty]:

It's only partially fixed.

fixed with ?

#4 Updated by Borys Jurgiel over 11 years ago

Yes, now is fine. Can we patch also the 1.0.x branch?

#5 Updated by Jürgen Fischer over 11 years ago

  • Status changed from Feedback to Closed
  • Resolution set to fixed

Replying to [comment:4 borysiasty]:

Yes, now is fine. Can we patch also the 1.0.x branch?

applied in

#6 Updated by Anonymous about 11 years ago

Milestone Version 1.0.1 deleted

Also available in: Atom PDF