Bug report #14467

QGIS Desktop 2.14 breaking shapefiles during session

Added by Andrew Abbott over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Vectors
Affected QGIS version:2.14.0 Regression?:No
Operating System: Easy fix?:No
Pull Request or Patch supplied:No Resolution:duplicate
Crashes QGIS or corrupts data:Yes Copied to github as #:22445

Description

I am using QGIS Essen 2.14.0 and doing some digitising. When part-way through a session, and when I pan the map (although possibly notr limited to this), I am suddenly losing several of the shapefiles which I had been working on in the session. This is only happening to shapefiles which I had been editing in the session. Crucially, this seems to be happening even when I am not currently editing the shapefiles.

Even if I immediately close the map document without saving, and reopen the document, the shapefiles are unable to be loaded and I get the 'handle bad layers' prompt. If I then try to add the shapefiles manually, I get the error message 'Invalid Data Source: filename.shp is not a valid or recognized data source'.

This is despite the fact that all five constituent parts of the file still exist.

I do not get this issue if I revert to using 2.12.

History

#1 Updated by Giovanni Manghi over 4 years ago

  • Target version deleted (Version 2.14)
  • Priority changed from Severe/Regression to High
  • Status changed from Open to Feedback

Hi, it is a blocker if it is a regression, and we should confirm it. Please attach sample data, ideally a shapefile that is ok and its corrupted copy. Also it would be very good to know what exact steps are needed to replicate this issue, and also to know if you are using 3rd party plugins to edit/digitize data.

#2 Updated by Giovanni Manghi over 4 years ago

  • Resolution set to duplicate
  • Status changed from Feedback to Closed

closing for lack of feedback and because seems duplicate of #14711

Also available in: Atom PDF