Bug report #14464

Full zoom fails if a filter query is defined on shp vector layer

Added by Christophe Damour over 4 years ago. Updated over 4 years ago.

Status:Closed
Priority:High
Assignee:-
Category:Map Canvas
Affected QGIS version:2.14.0 Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied:No Resolution:fixed/implemented
Crashes QGIS or corrupts data:No Copied to github as #:22442

Description

If a filter query is defined on a shp vector layer, full zoom fails and every zooming function stop working until filter query is removed. Tested with several shp layers, works fine on 2.8.7, works fine with spatialite layers.

COMMUNES.zip (5.42 KB) Christophe Damour, 2016-03-12 02:27 AM

History

#1 Updated by Christophe Damour over 4 years ago

A shp layer on which the bug can be reproduced is attached to this message.

#2 Updated by Anita Graser over 4 years ago

Tested with the query

"NOM" IN ('FUSSY','ANNOIX','LE SUBDRAY')

and cannot reproduce the issue on Win8 with 2.14 or master. Can you add more details?

#3 Updated by Christophe Damour over 4 years ago

Well, I tested again with your query and I have the same problem.
It occurs when I click "full zoom" button or when I select "zoom to layer" in the contextual menu.
Other navigation functions don't seem to be affected.

#4 Updated by Anita Graser over 4 years ago

Are you using a provider filter (Layer properties | General | Provider feature filter) or something different? Any output in the Log Message Panel (speech bubble button in the bottom-right corner of the main window)?

#5 Updated by Christophe Damour over 4 years ago

I am indeed using the provider filter, and there is no error in the Log Message Panel.
I tried to remove every plugins, but still got the same problem.

#6 Updated by Anita Graser over 4 years ago

  • Resolution set to fixed/implemented

You're right, confirmed in 2.14.0 release, but seems fixed in 2.14 dev and master.

#7 Updated by Christophe Damour over 4 years ago

Great ! Thank you very much for your help.

#8 Updated by Anita Graser over 4 years ago

  • Status changed from Open to Closed

Also available in: Atom PDF