Bug report #1445

mapserver export fails in Windows XP

Added by Markus Neteler almost 12 years ago. Updated about 11 years ago.

Status:Closed
Priority:Low
Assignee:Marco Pasetti -
Category:Python plugins
Affected QGIS version: Regression?:No
Operating System:Windows Easy fix?:No
Pull Request or Patch supplied: Resolution:worksforme
Crashes QGIS or corrupts data: Copied to github as #:11505

Description

Hi,

the following message appears when trying to export a SHAPE layer to mapfile:

Fehler bei der Ausführung von Python-Code:

Traceback (most recent call last):
  File "C:/Programme/Quantum GIS\\./python/plugins\\mapserver_export\\mapserverexport.py", line 81, in run
    exporter = Qgis2Map(str(self.dlg.ui.txtQgisFilePath.text()), str(self.dlg.ui.txtMapFilePath.text()))
  File "C:/Programme/Quantum GIS\\./python/plugins\\mapserver_export\\ms_export.py", line 38, in +init+
    self.qgs = minidom.parse(projectFile)
  File "C:/Programme/Quantum GIS\\./python\\xml\\dom\\minidom.py", line 1913, in parse
    return expatbuilder.parse(file)
  File "C:/Programme/Quantum GIS\\./python\\xml\\dom\\expatbuilder.py", line 922, in parse
    fp = open(file, 'rb')
IOError: [Errno 2] No such file or directory: _

Python-Version:
2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)]

Python-Pfad:['C:/Programme/Quantum GIS\\\\./python', 'C:/Dokumente und Einstellungen/rf/.qgis//python/plugins', 'C:/Programme/Quantum GIS\\\\./python/plugins', 'C:\\\\Programme\\\\ArcGIS\\\\bin', 'C:\\\\Programme\\\\Quantum GIS\\\\python25.zip', 'C:\\\\Python25\\\\Lib', 'C:\\\\Python25\\\\DLLs', 'C:\\\\Python25\\\\Lib\\\\lib-tk', 'C:\\\\Programme\\\\Quantum GIS', 'C:\\\\Python25', 'C:\\\\Python25\\\\lib\\\\site-packages']

Apparently the dot in the path breaks the functionality (the files are present).

History

#1 Updated by Jürgen Fischer almost 12 years ago

seems like a packaging issue. works nicely with the msvc build and a local python install.

#2 Updated by Marco Pasetti - almost 12 years ago

I made a simple test: I exported a shp file and it worked fine.
I asked to Leo (Lami) to test it too.
I would wait for his tests before to decide if it is a real package bug.

Marco

#3 Updated by Marco Pasetti - almost 12 years ago

  • Resolution set to worksforme
  • Status changed from Open to Closed

Leo reported no errors too.
I'm closing the ticket as works for me.

Marco

#4 Updated by Markus Neteler almost 12 years ago

Mhh, I am suprised that I then see a ghost error... well, ok. I hope for the next package then.

#5 Updated by Anonymous about 11 years ago

Milestone Version 1.0.0 deleted

Also available in: Atom PDF